Technology

Older iPhones need this update by tomorrow, or they won't work properly

Older iPhones need this update by tomorrow, or they won't work properly

If you've managed to hang on to your iPhone 4 or 5 for all these years: Congratulations! You've successfully navigated a yearslong gauntlet of cracked screens, toilet drops, theft, peer pressure and seductive advertising to cling to the vintage device.

But now you'll have to clear yet another hurdle to keep these phones and other older Apple gadgets working properly. Fortunately, it's a pretty simple process.

Apple announced that owners of devices introduced in or before 2012 will have to install software updates to accommodate a rollover in Global Positioning System (GPS) that took place in April.

iPhone 5 users must install update 10.3.4 via wireless or computer by Sunday to keep the GPS, cloud, email, app store and other features functional. If users miss that deadline, they will need to take a slightly more arduous route of backing up and then restoring their phones via a computer.

To check that the software is up to date, users can navigate to the "Settings" menu, choose "General," and select "About" from the list of options to verify the correct software has been downloaded.

Those in possession of an iPhone 4 or certain early versions of the iPad will need to install software version 9.3.6, or their GPS and other services may not work properly after Sunday.

If you still have any of these devices, don't let this update fall by the wayside. You've already made it so far.